Comandos de configuración de dispositivos cisco

Comandos de configuración de dispositivos cisco

CONFIGURACIÓN GENERAL

Configuración del nombre de host

Router> enable                                                              modo privilegiado
Router# config terminal                                               Modo de Config
Router(config)# hostname myRouter                         Nuevo nombre: myRouter

Configuración de las contraseñas

Contraseña de acceso a consola

Router> enable                                                               modo privilegiado
Router# config terminal                                                Modo de Config
Router(config)# line console 0                                    config consola
Router(config-line)# password cisco                         contraseña de acceso
Router(config-line)# login

 

Contraseña de acceso a modo privilegiado

Router> enable                                                                  modo privilegiado
Router# config terminal                                                   Modo de Config
Router(config)# enable password cisco                        Contraseña: cisco

 

Contraseña secreta de acceso a modo privilegiado

Router> enable                                                                 modo privilegiado
Router# config terminal                                                  Modo de Config
Router(config)# enable secret cisco                             Contraseña: cisco

 

Contraseña Terminal virtual (Telnet)

Router> enable                                                                 modo privilegiado
Router# config terminal                                                  Modo de Config
Router(config)# line vty 0 4                                            Config puerto virtual
Router(config-line)# password cisco Contraseña: cisco
Router(config-line)# login

 

Configuración servidor SSH

Router> enable
Router# config terminal
Router(config)# hostname R2
Router(config)# ip domain-name cisco.com
Router(config)# crypto key generate rsa
Router(config)# username felipe secret cisco
Router(config)# line vty 0 4
Router(config-line)# transport input ssh
Router(config-line)# login local
Router(config)# ip ssh time-out 15
Router(config)# ip authentication-retries 2

 

Mostrar el running-config y mostrar configuraciones

Router> enable
Router# show run

 

Guardar cambios

Router> enable
Router# copy run start
Router# write

Guardar cambios

Router(config)# line console
Router(dhcp-config)# logging synchronous

 

Configuración de interfaces

 

Configuración de la interfaz FastEthernet 0/0

Router> enable                                                                                 Modo privilegiado
Router# config terminal                                                                  Modo de Config
Router(config)# interface fastEthernet 0/0                                 Config Interfaz
Router(config-if)# ip address 192.168.1.1 255.255.255.0        Asignación IP
Router(config-if)# clockrate 56000                                              Tasa de transmisión
Router(config-if)# no shutdown                                                    Activación Interfaz

 

Configuración de la interfaz WAN Serial 0/0/0

Interfaz Serial DCE (Proporciona el reloj)

Router> enable                                                                                 Modo privilegiado
Router# config terminal                                                                  Modo de Config
Router(config)# interface Serial x/y/z                                          Config Interfaz
Router(config-if)# ip address 192.168.50.5 255.255.255.0      Asignación IP
Router(config-if)# clockrate 56000                                              Tasa de transmisión
Router(config-if)# no shutdown                                                    Activación Interfaz

 

Interfaz Serial DTE

Router> enable
Router# config terminal
Router(config)# interface Serial 0/0/0
Router(config-if)# ip address 192.168.50.7 255.255.255.0
Router(config-if)# no shutdown

 

Interfaz de loopback

Router> enable
Router# config terminal
Router(config)# interface loopback number
Router(config-if)# ip address ip-address subnet-mask

Determinar qué extremo del cable DCE o DTE está conectado a esa interfaz serial

Router# show controllers serial 0/0/0

 

Configuracion del servidor DHCP

Router(config)# ip dhcp pool POOL1 Pool de direcciones
Router(dhcp-config)# network 192.168.1.0 255.255.255.0 Red para POOL1
Router(dhcp-config)# dns-server 192.168.1.10 Servidor DNS
Router(dhcp-config)# default-router 192.168.1.1 Router por defecto
Router(dhcp-config)# exit
Router(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.49
Router(config)# show ip dhcp binding (Mostrar asignaciones DHCP)
Router(config)# show ip dhcp pool (Mostrar ambitos o pool DHCP)

 

Configurar una interfaz del route como cliente DHCP

Router# configure terminal
Router(config)# interface f0/0
Router(config-if)# ip address dhcp
Router(config-if)# no shutdown

 

Relay DHCP

Router# configure terminal
Router(config)# interface f0/0
Router(config-if)# ip helper-address 192.168.2.1 (Dirección IP del servidor DHCP)
Router(config-if)# no shutdown

 

Depuración de DHCP

Router(config)# debug ip dhcp server events

 

Historial de comandos

Router# terminal history
Router# terminal history size 50
Router# terminal no history size 50
Router# terminal no history size 50

ENRUTAMIENTO (ROUTING)

 

Comportamiento de enrutamiento

Router(config)# no ip classless
Router(config)# ip classless

Rutas estáticas

Router(config)# ip route [IP Red destino] [Mask red destino] [IP Interfaz siguiente router | Interfaz de salida]

 

 Verificación de rutas

Router# debug ip routing
Router# show ip route
Router# show ip route [Dirección IP de la red]
Router# show run
Router# ping [Ruta de destino]

 

 Eliminación de rutas:

Router(config)# no ip route [IP Red destino] [Mask red destino] [IP Interfaz siguiente router | Interfaz de salida]

 

 Caso especial para una interfaz de salida fastEthernet

R1(config)# ip route 192.168.2.0 255.255.255.0 [Interfaz de salida] [IP Interfaz siguiente router]

Rutas por defecto

Router(config)# ip route 0.0.0.0 0.0.0.0 [exit-interface | ip-address ]

Enrutamiento dinámico RIP

Router> enable
Router# config terminal
Router(config)# router rip
Router(config-router)# network [dirección de red con clase directamente conectada]

 

 Impedir actualizaciones innecesarias

Router(config)# router rip
Router(config-router)# passive-interface FastEthernet 0/0 (No se realiza broadcast por esta interfaz)

 

 Desactivar RIP

Router(config)# no router RIP

 

 Propagar la ruta estática por defecto «quad-zero» en las actualizaciones RIP

Router(config-router)# default-information originate

 

 Enviar fuente de enrutamiento estático a otra fuente de enrutamiento

Router(config-router)# redistribute static

 

 Rip versión 2

Router(config)# router rip
Router(config-router)# version 2

 

 Deshabilitar el resumen automatic de rutas

Router(config)# router rip

Router(config-router)# no auto-summary

 

 Verificación y resolución de problemas:

Router# show ip interface brief
Router# show ip route
Router# show ip protocols
Router# debug ip rip
Router# show ip rip database
Router# undebug all

 

NOTA: Las siguientes recomendaciones son útiles para la solución de problemas:

1. Asegúrese de que todos los enlaces (interfaces) estén activados y en funcionamiento.
2. Verifique el cableado.
3. Verifique que tiene la máscara de subred y dirección IP correcta en cada interfaz.
4. Elimine los comandos de configuración que sean innecesarios o se hayan reemplazado con otros comandos.

 

Enrutamiento dinámico EIGRP

NOTA:  EIGRP utiliza los siguientes valores en su métrica compuesta para calcular la ruta preferida hacia una
red:

 Ancho de banda
 Retraso
 Confiabilidad
 Carga

Router(config)# router eigrp [autonomous-system]
Router(config-router)# network [dirección de red con clase directamente conectada]

 

 No incluir interfaz en EIGRP

Router(config-router)# network network-address [wildcard-mask]
R2(config-router)# network 192.168.10.8 0.0.0.3

 

 Modificar el ancho de banda

Router(config-if)# bandwidth [kilobits]

 

 Verificación y resolución de problemas:

Router# show ip eigrp neighbors (Muestra los vecinos EIGRP)
Router# show ip protocols
Router# show ip route
Router# show interface (Visualización de BW y del retraso)
Router# show ip eigrp topology
Router# show ip eigrp topology [Network]

Enrutamiento dinámico OSPF

Router(config)# router ospf [process ID]
Router(config-router)# network [network-address] [wildcard-mask] area [area-id]

 

 Configuración manual del Router-ID

Router(config)# router ospf process-id
Router(config-router)# router-id ip-address

 

 Volver a cargar el router

Router# clear ip ospf process

 

 Verificación y resolución de problemas:

Router# show ip protocols (Visualizar Router ID)
Router# show ip route
Router# show ip ospf
Router# show ip ospf interface
Router# show ip ospf neighbor

 

 Modificar el costo:

R1(config)# interface serial 0/0/0
R1(config-if)# ip ospf cost 1562

 

 Propagar la ruta estática por defecto «quad-zero» en las actualizaciones RIP

Router(config)# router ospf [process ID]
Router(config-router)# default-information originate

 

 Forzar la prioridad de una interfaz

NOTA: Debido a que las prioridades son un valor específico según la interfaz, suministran un mejor control de las redes de accesos múltiples de OSPF. También permiten a un a router ser DR en una red y DROther en otra.
Router(config-if)# ip ospf priority {0 – 255}

 

 Modificación de intervalos OSPF

Router(config-if)# ip ospf hello-intervalseconds
Router(config-if)# ip ospf dead-intervalseconds

 

RECUPERAR CONTRASEÑAS

1. Detener el boot (puede hacerse mediante ctrl+espacio o si usas teraterm control -> send break).
2. Ejecutar el comando: Rommon1>confreg 0×2142 (hacemos que el router al arrancar no cargue
la configuración).
3. Ejecutamos el comando Rommon2>reset (reiniciamos el router).
4. Al iniciar preguntará si se desea usar un asistente para la configuración rápida, nosotros de
momento decimos que no.
5. Router#enable
6. Router#erase startup-config (borra la configuración inicial)
7. Router#conf t (comenzamos a configurar)
8. Router(config)#config-register 0×2102 (para dejar el registro tal cual estaba originalmente, y
poder cargar la configuracion en los sucesivos arranques, deshacer lo anterior hecho vamos).
9. Reiniciar sin guardar configuración y sin volver a parar el boot. Para esto ejecutamos el siguiente
comando: Router#reload

Espero que os sea de ayuda.  

 

Julio

Me llamo Julio y soy un apasionado de la informática. Estoy muy contento de que mi blog apuntesjulio.com os sirva de ayuda para conocer un poco más el mundo de las nuevas tecnologías. Espero que os guste 😉 Gracias por la visita !!

2 comentarios en «Comandos de configuración de dispositivos cisco»

Deja un comentario

A %d blogueros les gusta esto: